Recovering Your Battery (1st Gen Only)

If you’re experiencing any of the following issues, it might be because your battery pack naturally discharged too far: Board won't turn on. Board won't respond to the charger. Board turns on but then displays a blinking pattern. Board displays a blinking pattern when the charger is connected.

You can recover the battery yourself without having to send the board into us.

To start, you need to have the wheels spinning enough to give the board a small regenerative charge. This can be done by kicking the board around for 15-20 min at about 10mph, or even by being creative and having someone pull you around with a bike. We’ve even seen someone use a treadmill or a hand drill setup to get the wheels spinning for a while. Whatever method you use, please use caution. Keep the board turned off when you try this, and then immediately plug it into the charger without turning on the board or remote.

Try checking the remote or the app to see if it’s actually gaining charge after 15 minutes on the charger again. If after a couple attempts your board still doesn't charge normally, please reach out to us to diagnose the board further.

Was this article helpful?
136 out of 219 found this helpful

Comments

6 comments

  • Avatar
    Jacben

    What if it’s fading green then switches to read?

  • Avatar
    Elvisvarner

    My board power button  flashed 3 times and the 80% battery light stays solid. I tried leaving it plugged in over night and even tried the power drill rolling the wheels forward for 25 minutes. I even tried backwards 25 minutes. Nothing worked. I was getting 10 miles on a extended range but after about 12  rides it would charge but only get 6 miles. This website said to run the wheels till they stop spinning then charge it to get full charge  but after I did that this problem has been around. I see people on reddit have the same problem but nothing has been fixed for them  as well. Its been 8 days since I requested help and I was told was that the battery got to low and i should plug it in for 15 minutes and if that doesnt work to let them know. I replied to them I already tried that and them some but still no response.

  • Avatar
    Jim Hammersley

    Used my wife’s treadmill, worked like a charm, thanks. I’m riding my Gen 1 again until my stealth gets here. Thanks for a great fix.

    Jim Ham

  • Avatar
    John Bryan Lee

    My Gen 1 2+ sat for a couple of months without a charge. The battery light blinked red when on charge and the switch would not turn on the board. Following this recovery procedure brought the battery up to the point that the charger could take over. All systems are now fully functional.

  • Avatar
    Nancy White

    I have the same problem, it was blinking red, after doing the treadmill thing it is now solid green, than solid red than green flashing than turns off

  • Avatar
    Stephen Carbajal

    Has there been any support with this issue?

Please sign in to leave a comment.

Can't find what you're looking for?

Contact Us